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1 Introduction 
This manual instructs in how to create drawing borders using Visio 2010, and input fields into 
the  border to enable the user to fill in drawing information such as title, drawn-by, etc. via a 
data input screen.  The drawing border becomes a Visio Shape and the information entered is 
known as Shape Data (up to and including Visio 2003, Shape Data was known as Custom 
Properties).  A HarnWare Drawing Border Properties function facilitates the completion of 
information boxes in all sheets in the drawing file if the user desires. 
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All other pages in the file such as Parts List, Wire List, and Labour Estimate etc. have unique 
names and do interface with HarnWare.  They contain specific properties that enable 
HarnWare to recognise them and edit data associated with the drawing file.  Pages can have 
different designs of border with a different number of information boxes but providing the 
fields are identified identically the Drawing Properties tool will operate on them.  For 
example, the Labour Estimate page has less room for the information boxes so fewer are 
possible and these normally contain the basic drawing information.  This manual also 
instructs in how to edit these pages in the Sheets stencils and HarnWare templates. 
 
Important Information:  Standard company specific A4 to A0 or A to E size drawing 
borders can be stored on a stencil with a name of the designers choosing.  All other pages 
must be stored on a stencil called Sheets-Metric or Sheets-Imperial for HarnWare to operate 
correctly.  It is recommended, however, that all drawing pages are stored on the Sheets 
stencils for simplicity.  The Sheet stencils normally open with the standard HarnWare 
template. 
 
This manual is written for users of Visio 2010 although the principles described apply to most 
versions of Visio with some minor variations. 

2 Drawing Border 
Use this procedure to create borders for all sizes of page from A4 to A0 or A to E.  It is 
recommended that a start is made with A3 or B as the contents of this size can generally be 
made common to all page sizes.  Some minor adjustments may be required but keeping as 
much commonality as possible across the sizes reduces work, minimises transcription errors 
and ensures the Shape Data remains constant, thus reducing the need to edit pages 
individually. 
 

2.1 Outer Frame 
Create the outer frame using the Rectangle Tool from the Drawing toolbar then select No Fill 
from the Fill menu.  Check that Snap to > Grid is selected in the Tools > Snap and Glue 
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menu.  This will ensure that the rectangle snaps to the grid and its size has a round number 
making it easier to populate with information boxes.   
 

 
 

Allow a gap around the outside of the border as shown.  At this stage it is recommended that a 
print trial be carried out and the border adjusted if the required output, either in size or 
centrality, is not achieved. 

2.2 Information Boxes 
Use the Rectangle Tool to create un-filled information boxes inside the drawing frame. 
 

 
 

Select each box and type a title.  In this example the text has been aligned top left.  Note that 
the Format Text toolbar will need to be open to access vertical text alignment tools.  Set the 
text height to suit. 
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At this stage a company logo can also be added and any other features that form part of the 
standard company border such as a tolerance box, drawing projection icon, XY coordinate 
graduations, notes, etc.  
 

 
 
We now need to add text boxes to every box in the border that requires variable data to be 
edited from the Visio, Shape Data screen.  Drag a text box in a position that will give the 
clearest legend and type a character – in this example an X.  Set the text to the chosen height.  
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2.3 Shape Sheet 
Once you have added the boxes, both for the headers and for the text, you need to group the 
whole page. Press Ctrl+A to Select All then Ctrl+G to group. 
 

 
 

 
 

Select the border which is now a group and open its ShapeSheet.  To do this click Developer> 
Show ShapeSheet or right click over the border to Show ShapeSheet. 
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When the Shape Sheet is open, right click a table header and insert the Shape Data section. 
 

    
 

Once the Shape Data section has been added add one row for each editable text box.  In this 
example 8 rows are required. To do this right click the first row in the Shape Data section and 
click Insert Row.  Repeat until 8 rows have been created or use the F4 key to repeat last 
command. 
 

 
 

Note that both Insert Section and Insert Row can be accessed via the Shape Sheet toolbar. 
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Re-label the Shape Data properties name from ‘Row_1’ to something more meaningful such 
as ‘Title’ or ‘PartNumber’.  Click the cell you wish to edit and type the new text in the Shape 
Sheet formula bar.  Note: 
 

1. The word ‘Prop’ remains so simply edit the name of shape data, e.g. ‘Title’. 
2. The name must be a single text string with no spaces, i.e. ‘PartNumber’. 
3. For the Label and Prompt columns insert the text between the quote marks. 
4. For the Date property, change the ‘0’ to ‘5’ in the Type column.  This will give a 

clickable calendar when editing Shape Data. 
 
When you have finished editing, click the check box or hit the Return key to enter the edits 
into the Shape Sheet cell. 
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Edit the Events section of the Shape Sheet and enter ”=DOCMD(1312)” into the 
‘EventDblClick’ cell.  This opens the Shape Data box when the drawing border is double 
clicked. 
 

 
 

Close the Shape Sheet.  Edits will be automatically saved. 
 

2.4 Insert Fields 
 
Select the drawing border then go to the Developer>Shape Name menu and record the name 
of the border shape.  In this example it is Sheet. 5. 
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With drawing border still selected, select one of the text boxes previously added to the border 
information boxes. 
 

 
 

Click on the Insert>Field menu to open the Field screen. 
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Choose the Custom Formula category and edit ‘=Sheet.5!Prop.Title’ as shown below where 
Sheet.5 is the border name and ‘Title’ is the name given to the border information box. 
 

 
 

Repeat the above procedure for all boxes and test by double clicking the border.  If all’s well 
the Shape Data box will open showing the label and prompt and the fields can be edited.  
Click OK and the data will be transferred to the drawing border. 
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To add page number and number of pages add text fields in the border as shown below.   
 
 

 
 
 

 
Select each field in turn and use the Insert > Field command to insert Page Number and 
Number of Pages. 
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2.5 Drawing Properties 
 

In order for the HarnWare, Drawing Properties tool to work all sheets need to have their class 
specified by using the Developer>Shape Name command and editing {Class=Drawing 
Border} in the Data 1 field.  Developer>Shape Name can be accessed from the main toolbar. 
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3 Stencils 
Drawing borders can be added to a new stencil or overwrite the borders in the Sheets-Metric 
stencil. 

3.1  New Stencil 
Open a new stencil using the Shapes tool from the Visio tool bar. 
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At this stage, edit the Shape Data by double clicking the border so that the text in the 
information boxes is replaced by a ‘-‘ as this will become the master shape for this size of 
drawing border. 
 

 
 
 
Select the border and drag it into the new stencil.  Right click the new icon in the stencil and 
select Edit Master>Edit Master Shape.  Select the newly created border that is now open and 
‘Show Shape Sheet’ as per Paragraph 2.3.  
 
Move to the top of the Shape Sheet to the Shape Transform section and enter 
‘GUARD(ThePage!PageWidth/2)’ in the ‘PinX’ cell and ‘GUARD(ThePage!PageHeight/2)’ 
in the ‘PinY’ Cell.  This will snap the border to the centre of the page when dragged onto the 
drawing. 
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Close the Shape Sheet.  Edits will be automatically saved.  Save the stencil.  Test by dragging 
the sheet into the drawing.  It should snap to the centre of the page.  Double click the border 
shape to open the Shape Data dialogue box. 
  
 

 
 

 
Right click the new icon in the stencil and select Edit Master>Master Properties.  Add a new 
name, a prompt and keywords and it is suggested that the two behaviour boxes are un-
checked.  The suggested icon size is 32 x 32, centre aligned. 
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Right click the new stencil tool bar icon and choose Properties.  Edit the Title to the name 
chosen for the stencils 
 

     
 
The icon can also be edited at this stage if desired.  Right click the new icon in the stencil and 
select Edit Master>Edit Icon Image. 
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The Visio icon edit program is started and the icon can be edited to the desired design.  This 
manual does not instruct in icon editing but once the program is open its use is self 
explanatory.  
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Right click the new stencil tool bar icon and choose Save As.  Edit the file name to that 
chosen for the new stencil. 
 

 

3.2 Existing Sheets Stencil 
 
The simplest way of creating a company specific Sheets-Metric or Sheets-Imperial stencil is 
to edit the standard one shipped with HarnWare.  For safety it is recommended that a copy of 
the standard stencil be taken and renamed before commencing with changes.  The following 
procedure applies to all pages in the stencil. 
 
With your new drawing border open in Visio, open the Sheets-Metric or Sheets-Imperial 
stencil. 
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Right click the stencil icon and select Edit Stencil. 
 

     
 

 
Select the new drawing border and copy it.  Right click the sheet icon that you are going to 
edit and select Edit Master>Edit Master Shape.  In this example it is A3. 
 

 
 

This will open the standard A3 sheet master shape.  Select and delete it then paste in the new 
one, close and save the shape followed by saving the stencil.  The icon can now be edited if 
desired.  Test by dragging the new shape into the page.  It should snap to the centre upon 
release of the mouse and by double clicking it Shape Data will open.  Repeat for all page 
sizes. 
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New Border 
Pasted in

 
 

4 Other HarnWare Pages 
All other pages such as Parts List, Wire list, Labour Estimate etc. interface with HarnWare. If 
changes to these pages to make them company specific is desired, it is recommended that the 
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standard Sheets stencil and template be edited as follows and as described in Paragraph 3.2.  
The name of these pages is recognized by HarnWare and must not be edited. 

4.1 Parts List 
 
The HarnWare Parts List 1 opens as part of the standard HarnWare template and a Parts List 
border is stored in the Sheets stencil.  When the Parts List tool is used, HarnWare populates 
the page in the template and opens further pages automatically if the number of parts exceeds 
the maximum for a single page.  These are named Parts List 2, Parts List 3, etc.  The border 
for the extra pages is taken from the Sheets Stencil and parts list lines are taken from the 
Miscellaneous Stencil, one for each in the Parts List.  At present changes to column width, 
quantity of columns, or position of columns are not possible; contact Tyco Electronics for 
advice.  
 
In order to retain the existing parts list page properties it is recommended that the existing 
parts list border be edited.  It is also recommended that the outline and column headers etc. 
are retained.  Note that a single parts list line is already positioned in the sheet and should be 
retained.  Connection points, designated by a blue cross are also positioned at the top and 
bottom of the table and it is these that determine where the list starts and ends.  If the new 
border information boxes are a different size to the standard then it is likely that the end 
connection point will have to be moved.  Open the parts list group by right clicking on the 
Parts List 1 border in the template and click Group>Open Parts List. 
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Make the edits to the border as required.  It may be possible to copy and paste the information 
boxes or parts of the information boxes from the sheets already edited.  
 

 
 
When pasting into the group the copied shapes may not move.  To solve this problem, close 
the group and open the Shape Sheet for the border.  Find the Group Properties section and 
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change the ‘DontMoveChildren’ cell from TRUE to FALSE then close the Shape Sheet.  
Edit>Open Parts List to carry on editing the border.    
 

 
 
Continue to edit the border in line with paragraph 2.  Note: 
 

1. Remember that the shape is already a group. 
2. When adding property fields per Paragraph 2.4 you will find that the name of the sheet 

will not be Sheet.5 or similar but will have the sheet name, i.e. Parts List.  To add the 
fields use Sheet.1 as the identifier in all cases, e.g. ‘=Sheet.1!Prop.Title’. 

 
To move the End List Connection Point, select the Connection Point Tool from the Visio tool 
bar.  The mouse pointer will feature a connection point.  
 

 
 

In this example the End List Connection Point will need to be moved up the page to avoid 
Parts List lines overlapping the information boxes. 
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The new position should be about 5mm above the uppermost line in the information boxes in 
the X axis and can be anywhere across the page in the Y axis.  Position the mouse pointer 
over the connection point, left click (the cross will turn pink and the Parts List page will 
automatically be selected) and drag the point to the new position.  
 

 
 

When finished, leave a copy of the new page design in the template and following the 
procedure in Paragraph 3.2 replace the standard Parts List border with the new design in the 
Sheets stencil. 

4.2 Wire List 
Like the Parts List, the Wire List is stored in the Template and the Sheets stencil.  The Wire 
List also has Start List and End List Connection Points to accommodate multiple pages of 
wiring information.  Therefore the procedure for the Wire List is the same as for the Parts List 
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with the exception that the dimension of the End List Connection Point is 10mm above the 
uppermost line on the new information boxes. 

4.3 Wiring Schedule 
The Wiring Schedule also has Start List and End List Connection Points to accommodate 
multiple pages of wiring information.  The Wiring Schedule is an alternative to a Wiring 
Schematic and is optional.  Therefore it is not stored as a page in the template but only in the 
Sheets stencil but the procedure for creation is the same as for the Parts List. 

4.4 Labour Estimate 
The Labour Estimate page is stored only in the template and does not have a master in the 
Sheet stencil.  It analyses the drawing and wire list and acts like spread sheet so it is strongly 
advised that, whilst editing the border, fields in the body of the page are not edited or moved.  
Shape Data fields can be added in the same way as all other borders, as described in 
Paragraph 2.4.   

4.5 All Other Pages 
The Notes, Design Checker, Marker, RoHS and Weight borders are not stored in the 
HarnWare template but all have masters in the Sheets stencils.  To edit them, drag each shape 
onto a page, make the design changes in line with Paragraph 4.1 but once the new master 
shape in the stencil has been created and has been tested the original can be deleted as it does 
not form part of the template.  Please Note: 
 

1 The Checker and Notes borders have a box with no outline embedded in the master 
shape containing a text string that is used to define the start position and size of the 
text, and the extent.  This should be left intact during editing. 

 

              
 

2 The Weight and RoHS borders have a text line that defines start position, text height, 
row height, and column position and width.  This should be left intact during editing. 
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5 The Template 
At this stage you will have designed all new drawing borders and created masters in a new 
Sheets- Metric or Sheets-Imperial stencil.  The masters will be groups with Shape Data fields 
specified such that double clicking the border and using the Visio Shape Data screen, or using 
the HarnWare Drawing properties tool will enable you to add drawing information into the 
border(s). 
 
You will also have redesigned the Parts List, Wire List and Wiring Schedule borders by 
modifying the existing standard border but retaining the frame, headers and columns.  You 
will have adjusted the End List Connection Points as required and you will have added shape 
data fields to match the new drawing borders.  The Parts List and Wire List will have masters 
in the Sheets stencil and a page will also be in the Template.  Both will have their first text 
line positioned in the page but not in the master and separate from the border shape.  The 
wiring Schedule will have a master in the Sheets stencil. 
 
The Notes, Design Checker, Marker, RoHS and Weight borders are not stored in the 
HarnWare template but all have masters in the Sheets stencils.  You will have redesigned 
them by modifying the existing standard borders but retained the frame, headers, columns and 
text lines as appropriate.  All borders will have a text string or text line defining text input 
requirements embedded in the shape. 
 
 

5.1 Saving the Template 
 
The standard HarnWare templates opened when creating a new harness drawing contain four 
stencils and four drawing pages.  They are called HarnWare – Metric or HarnWare- Imperial.  
The stencils are Connectors, Adaptors, Miscellaneous and Sheets, and the pages are A3 
Harness Drawing, Parts List, Wire List and Labour Estimate.  The Sheets stencil contains all 
sizes of drawing page as well as the supplementary pages. 
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A new company specific template can now be saved with the new Sheets-Metric or Sheets-
Imperial stencils included.  Other edits to the template can be made at this time if required.  
The opening Harness Drawing page can be set to an alternative size or edits to the time 
synthetics in the labour sheet can be made to suit local working practises. 
 
To save a new template go to Visio File>Save As, select Save as type and choose Template 
(*.vst).  Choose your new template name and save in the folder C:/Program 
Files>HarnWare>Template. 
 

   
 
When opening a File>New your template will be available for selection. 
 

 


