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1 Introduction

You can set up your own shapes and if you wish HarnWare to recognise the shape in the
part selection, wire routing and parts listing processes you will need to add the correct
information to the shape in the datal field. The Tools>Create shape menu option assists
with certain aspects of creating your own shapes for use with HarnWare.

Before selecting this menu option a single shape or group should be selected in Visio. As
some of the changes made by this option cannot be undone, it is advisable to make a copy
of your shape before using this option.

The more common part classes (connectors, adaptors, etc) are listed and when selected

provide a basic setting for the shape Datal field which is used to store most of the data
used by HarnWare.

2 Drawing a shape

When drawing shapes for parts such as connectors or adaptors you may need to omit the
geometry which is normally hidden when assembled with a boot.

If possible keep the drawing symmetrical about the part centre line. If not, try adding two
connection points and use the "Twist shape' option to realign the shape.

Generally shapes should be drawn with closed lines which can be filled to help shape
selection in Visio.
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Finished shapes must be grouped using the “Ctrl + Shift’ and ‘G’ command or by using
the menu option Home>Arrange>Group.
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3 Adding connection points

The opening positions in the part are indicated by two connection points which must be
added to the shape. In the case of a straight part, try to keep the drawing symmetrical
about the part centre line. For angled parts position the connection points at the opening

positions.

The connection point tool can be found in the menu option Home>Tools>Connection
point. Hold the Ctrl key and click where you want to add, move, or delete a connection

point.

g Pointer Tk 1~
B & Connector B | .
= A Text G
e Jaols L
25 30 3z 34 35

Page 30f 11



7\

0]

4 Using the HarnWare ‘Create Shape’ option

The HarnWare>Tools>Create Shape menu option assists with the main aspects of creating

your own shapes for use with

HarnWare.

By HarmWare

= [ 5 [ |

File  Edit

« | & |

Ready

Tools ‘ Options  Window  Help

<% Design Wizard M

&4 Database Search Ctrl+D

Wiring Schematic/Schedule 3
Wire Route Ctrl+W
Multi-Core Cable 3

Parts List Ctrl+L
Composite Parts List ...

Marker Page & Data Export ...

Check Design

Compare Designs

Labour Estimate Ctrl+E
CoP, Materials & Equipment  Ctrl+T
RoHS

Weight

B v m =

Composite Weight ...

K7 HamnVis Ctrl+H

mm| 25

Drawing Translator

Create shape ...

ﬂ Calculator Ctri+K

Before selecting this menu option a single shape or group should be selected in Visio. As
some of the changes made by this option cannot be undone, it is advisable to make a copy

of your shape before use.

¢ Create Shape

Part class:

Datal field:

Shape name:

Adaptor

FeedThrough
Hamess Leg
KTKK

Marker Slesve
Moulded Part

{Class=ConnectorH{Style=Unknown}

Sheet 444 [ Twist shape

[ ok ] [ Cancel | |

Help
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Clicking ‘OK” causes:

The "Twist shape' option is typically used for angled adaptors or
boots where the begin and end points of the One D shape need to
be adjusted to the positions of the openings in the part. As part of
the twist shape operation the shape height is set to zero so when the
shape is selected or dragged a line connects the begin and end

points.

EMND

The shape to be converted into a One D shape

Protection to be added to the width, height and aspect ratio

Right-click and double-click menu options to be added for opening the shape in
HarnWare and for accessing the Rotate option

The shape datal field to be set to the specified text

The shape name to be set

If the connector class is selected, a text is added to the
shape along with a control handle to control its position.
The text angle is also fixed. This text is used for the

connector reference.

¢ Create Shape |£|
Part class: daptor
Connector
FeedThrough
Hamess Leg
KTKK
Marker Slesve
Moulded Part
Datalfield: {Class=Adaptor}
Shape name: Sheet 444 [¥] Twist shape
[ ok | [ Cancel | [ Heb
Shape Name 'il
ID: 443
Master:  D38999/26:038999/26
Harn\Ware H Type:  Shape
Raotate h Mame: 03899928
= Help: HarnWare.chm! #6000
& Show ShapeSheet
Language: |English (U.K.) Iz‘
& Cut —
3 Copy /
ﬂ Paste Data 1: {Class=Connector}{Style =Plug}
[, Paste Special... EiaZ

Data 3:

OK ‘ l Cancel
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5 Datal field.

Extra information such as part numbers, dimensions and material details can be stored in
the Format Special>Data 1 field (or in Visio 2010 the Shape Name option in the
Developer tab), which will save re-entering the same details each time the symbol is used.
Each data item in the datal field is enclosed with '{" '}' brackets.

A useful way to establish these parameters (excepting Y and Z diameters) is to use an
existing shape and with HarnWare, search and save data to the shape in the normal
manner. Use the Visio 'Format Special’ menu option (or in Visio 2010 the Shape Name
option in the Developer tab) to inspect the shape’s datal field. If you copy and paste the
datal field into your shape, most of the HarnWare options will recognise it.

Moulded part transitions are more complicated to set up because opening names have to
be related to connections. Please contact HarnWare system support for further advice.

Rules for Data 1 entry are:
e Any combination (or none) of the characteristics shown below in red may be
included.
e Each item must be enclosed by curly brackets.

¢ No spaces or punctuation except within words or variables.

Part number & manufacturer Y diameter is used by Harm\Ware
will appear in the parts list to calculate the correct moulded

NN

{Class=Connectory{Style=Unknown}{ Part Number=C1-10-16}{Manufacturer=ABC Ltd}{YDia=16.0}
{ZDia=10.0{Contacts=Solder}

Z diameter, if included, is the 'Crimp’ or ‘Solder’ for the contacts
diameter through which the is used in the Labour Estimate
cable can pass

Shape Mame Léj

1D: 4

Master:  <no master>

Type: Shape

MName: My Connector

Help:

Language: |English (U.K.) E

Copyright:

Data 1: Jrer=ABC Ltd}YDia=16.0}4Z0ia= 10,0 Contacts =Solder}|
Data 2:

Data 3

oK ] [ Cancel
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6 Errors

Unfortunately a number of errors can occur while making these types of changes to Visio
shapes. A dialog will outline the action causing the problem along with some extra
information. This information should help identify the changes you will need to make to
your shape. Alternatively please contact HarnWare system support for advice.

In order to prevent accidental corruption of your shape when an element within the shape
is selected, usually when clicked for a second time, and moved, Group Properties>Don’t
Move Children in the Shape Sheet can be set to “TRUE’ from the default which is
‘FALSE’.

Open the Shape Sheet by right clicking the shape and selecting ‘Show Shape Sheet’.

HarnWare

EMD

Rotate

Show ShapeSheet

Scroll down to find Group Properties and Edit ‘FALSE’ to ‘“TRUE’.

Group Properties
SelectMode 1 IsTextEditTarget TRUE IDropTarget FALSE‘/
DisplayMode 2 IsSnapTarget| TRUE DontMoveChildren  TRUE

In certain circumstances you will get an error message as shown below which indicates a
line type that is incompatible with the Create Shape tool. The shape may also be
corrupted after running ‘Create Shape’. The line type must be changed as indicated in the
shape’s ShapeSheet Geometry section before repeating the Create Shape process (see
below).

r N
HarnWare

The shape's ShapeSheet geometry section

i contains row(s) otherthan a LineTo, MaveTo,
ArcTo or Elliptical Arc To paint(s). Please change
these rowi(s) and retry this option

oK ] l Help

For advice please visit: www hamware com.forum,’
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7 Stencils

Geometry 1 . - N -
Geometryl MoFill| FALSE Geometryl.NoLine | FALSE
Name | X | v | A
_I!._ MoveTo -2.8448 mm 44124 mm
2 : LineTe 16,0655 mm 16,6046 mm
3 | LineTe 255483 mm 1.8966 mm
_4__! LineTo 19.2449 mm -2.1675 mm
5 ] PolyLineTo Width*0.6667 Height*0.2183 Mo Formula
6 _ PolyLineTo Width*0.4898 Height*0.4286 Mo Formula
7 | LineTe | 2.5739 mm -3.9922 mm
—| =
8 | LineTo  -2.8448 mm 44124 mm
Qe
S — -
Geometryl NoFill FALSE i € st i ket [ sz |
MName | X .[
1 MowveTo  -2.8448 mm 4. Row type
2 LineTo | 16.0655 mm 1€ it
3 | LineTo | 25.5483 mm 1 v ke
4 LineTo 19.2449 mm 5 i Change t
) ArcTo
= Values S bt 'MoveTo!
b PolyLineTo| — | () EllipticalarcTo X
e 5 | Formulas = : LInETG:
| LineTo - 3 i@ PolyLineTo ArcT
8 | LineTo WView Sections... u ™1 MURESTo 5 _": 01
: ; : | = EllipticalArcTo
Protection nsert Section... =y Sp-lineSErt
LUCkadth 1 Delete Section ) Splineknat
LockHeight |1 ] bt
nsert Bow i
InEErepa| 1 E < InfiniteLine
AT Insert Row After (1 Ellipse
ey Delete Row
4 1l
Efpcaw! R L [ 0K ] [ Cancel
Change Row Type

Open a new stencil by clicking More Shapes and selecting New Stencil found at the

bottom of the list.

pF umaiﬂﬁ C

Elank PFicture Clip Chart Conti
Page ~ Art Drawmg b
Pages Niustrpfions Dia Visio Extras ¥
Shapes / ] [ Open Stencil..
More Shapes b E ] Mew Stencil (Metri)

= ] Mew Stencil (US Units) 4
Where are the shapes? e

ght: 43 Show Document Stencil |

Right click on the heading of the stencil and select ‘Save As’, rename as ‘My Stencil’, for
example, and save. The stencil remains open for editing until it has been closed for the
first time. After this, to edit, right click on the heading and select “Edit Stencil’ from the
drop down list.
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Shapes £ ;"E:)ﬂ||||||?P||||||||ﬁ|||||||
More Shapes » _E
Quick Shapes g_;
s

Stencil2 PRITEC
Stencil2
n el ! H Save
Drop Quick Shapes here

Save As..

| 5 Properties...
View 3
Order 3

Reset Stencil

Cﬂ Drawing Explorer Window

Float Window
£2  Close

8 Adding shapes to a stencil

The easiest way to add a shape to a stencil is simply to drag it on to the stencil which must
be open for editing. At that time, an icon is automatically created from the shape.

Clipboard Fant

Shapes < _:ﬂ L1
Mare Shapes 3 g_;
Quick Shapes _;
l My Stencil H] k=
My Stencil =
Drop Quick Shapes here _E
f Dragand =
&: drop o=
T TSS=\ shape R

Right click on the shape and click on ‘Edit Master>Master Properties’.

[ My Stencil

280

i My Stencil

Drop Quick Shapes here

[ﬁs cut

260

240

53 Copy

L‘]E Paste

220
|IIII LIl

Add to My Shapes 3

200

Add to Quick Shapes

New Master...

180

X Delete Master _;

. =

Edit Master ¥ Master Properties...
@ Hep [#  Edit Master Shape

Edit Icon Image
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Master Properties ol S )

This is the name that
appears in the stencil

Properties

Name: My Shape
Prompt: This is a shape used for training purposes ‘_____-- Enter d fL_J”er description
o Wwhich will appear as a

prompt when the shape

Iconsize: | Double (84 x 64) is hovered over
Align master name: () Left @ Center () Right

T~~~ Change to suit

Search

Keywords:

Uncheck to ensure
L. icon isn't over written

Behavior =1

[¥] Match master by name on drop /

[ Show live preview in Shapes Window 3

Click OK to save
i changes

OK Cancel

The shape stored in the stencil has three components:

1. The master which appears on the drawing when dragged from the stencil.
2. The icon which is what you see on the stencil.
3. A “‘ShapeSheet” which may be modified to provide an automatic link to HarnWare.

Once on the stencil the shape can be modified by right clicking on the shape and select
‘Edit Master>Edit Master Shape’ to open it. Alternatively drag the shape back on to the
drawing and make the edits, then reopen the master shape, delete the existing shape and
copy and paste the revised shape in its place.

9 Editing the shape icon

To edit the icon, right click on the shape and select ‘Edit Master>Edit Icon Image’ and
this will open the Visio Icon Editor. The icon size is specified in ‘master Properties’.

[ My Stencil

280

My Stencil

op Quick Shapes here

240 260

&=l

220

Add to My Shapes r
Add to Quick Shapes

200

Mew Master...

180

b4

Delete Master

Edit Master " Master Properties...

@ tep & Edit Master Shape

Edit Icon Image
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By using the colour palette, pencil and bucket tool the icon can be Fﬂ
edited.

o Eater

% cut D7 Area Select

= 2 A 1 B
cut i} Area Select » R & P 4 3
& = Vi </" ‘6 6 B3 Copy S lLassoselect A ] —
E3copy ‘SLasso select - oy Pencil Bucket Left  Right | Closelcon
L Pencil Bucket Left  Right | Closelcon ¥ Qear | E selectan Tool Tool Button~ Button~ | Editor
X Clear | £ select Al Tool Taol Buttan~ Button~ | Editar

Clipboard Select Paint Close
| Clipboard | Select | Paint Close —— — — —

[ Adaptors - Spin Lockvssilcon:SLC_80

E] StencilS:dcon:My Shape

Tips for creating a reasonable icon:

1. Uncheck the ‘Show live preview in Shapes Window’ dialogue to prevent the icon
being over written.

2. Anicon’s format can be copied from an existing icon i.e. background design and
colour combinations.

3. Use the left and right mouse buttons to speed up editing.

4. Ensure that the stencil is visible whilst editing the icon so the effect of changes can
be observed.

5. Shape details can be moved around in the icon by Lasso Select or Area Select and
dragging.

6. A quick way to create the shape detail in the icon is to copy and paste from Visio.
Some experimentation with size, line weight and colours will be required but the
final representation of the shape is usually more accurate.

7. Add text to the icon by copy and paste from Visio.

8. When drawing lines with the pencil tool, release the mouse regularly so that mouse
control errors that have to be undone do not remove the whole line.
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